CC Lancer - Dash not illuminating

Anything that buzz, glows or requires electrons.

Moderator: MGEC Committee

CC Lancer - Dash not illuminating

Postby elleGT on Mon Jan 02, 2012 1:58 pm

Hi, am hoping someone on here might be able to give me some advice. I have a CC Lancer and the tacho, speedo etc are not illumating in the cluster. Indicators, park light, check oil light etc are working fine. We've checked the fuses, and they all seem to be ok. We've also swaped the clusters over twice, and changed over light blubs. Still no luck. Even tried swapping the dimmer swtich over and no difference. Has anyone got any thoughts on what it might be?
Cheers
2006 Ralliart Colt (daily)
2003 CG LS Lancer (old daily) - For Sale
1993 CC GSR Lancer Silver - Jap Spec (track/street)
1993 CC GSR Lancer Purple (track hack/spares)
User avatar
elleGT
Committee Member
Committee Member
 
Posts: 156
Joined: Sun Mar 26, 2006 9:30 am
Location: Over the hills and far away...

Re: CC Lancer - Dash not illuminating

Postby Jonson on Mon Jan 02, 2012 4:46 pm

Have you checked to see you have power getting to the globes?
not something stupid like dimmers turned all the way down lol
Jonson
General Forum User
 
Posts: 1295
Joined: Sun Feb 04, 2007 9:50 am
Location: Adelaide

Re: CC Lancer - Dash not illuminating

Postby elleGT on Mon Jan 02, 2012 6:02 pm

haha yeah, if only that was the problem - it would be an easy fix then! We did checked the dimmer, even changed to another one and neither worked.
Will check and see if power is actually getting to dimmer switch/cluster.
Thanks for your help :)
2006 Ralliart Colt (daily)
2003 CG LS Lancer (old daily) - For Sale
1993 CC GSR Lancer Silver - Jap Spec (track/street)
1993 CC GSR Lancer Purple (track hack/spares)
User avatar
elleGT
Committee Member
Committee Member
 
Posts: 156
Joined: Sun Mar 26, 2006 9:30 am
Location: Over the hills and far away...


Return to Audio/Electrical

Who is online

Users browsing this forum: No registered users and 1 guest

cron